Categories
Cloud

Docker Image Scanning

Docker Hub Vulnerability Scanning enables you to automatically scan Docker images for vulnerabilities using Snyk. This uses the same technology as the docker scan command.

When you push an image to Docker Hub after enabling vulnerability scanning, Docker Hub automatically scans the image to identify vulnerabilities in your container images. Vulnerability Scanning allows developers and development teams to review the security state of the container images and take actions to fix issues identified during the scan, resulting in more secure deployments. The scan result includes the source of the vulnerability, such as OS packages and libraries, version in which it was introduced, and a recommended fixed version (if available) to remediate the vulnerabilities discovered.

Here is a small example of a image php:7.2 :

> docker scan php:7.2

Testing php:7.2…

✗ Low severity vulnerability found in tar
Description: CVE-2005-2541
Info: https://snyk.io/vuln/SNYK-DEBIAN10-TAR-312331
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > tar@1.30+dfsg-6

✗ Low severity vulnerability found in tar
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-TAR-341203
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > tar@1.30+dfsg-6

✗ Low severity vulnerability found in systemd/libsystemd0
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-305144
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ Low severity vulnerability found in systemd/libsystemd0
Description: CVE-2019-9619
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-342768
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ Low severity vulnerability found in systemd/libsystemd0
Description: Missing Release of Resource after Effective Lifetime
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-542807
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ Low severity vulnerability found in systemd/libsystemd0
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-570991
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ Low severity vulnerability found in sqlite3/libsqlite3-0
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-535712
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Low severity vulnerability found in sqlite3/libsqlite3-0
Description: Use After Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-565214
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Low severity vulnerability found in shadow/passwd
Description: Time-of-check Time-of-use (TOCTOU)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SHADOW-306205
Introduced through: shadow/passwd@1:4.5-1.1, adduser@3.118, shadow/login@1:4.5-1.1, util-linux/mount@2.33.1-0.1
From: shadow/passwd@1:4.5-1.1
From: adduser@3.118 > shadow/passwd@1:4.5-1.1
From: shadow/login@1:4.5-1.1
and 1 more…

✗ Low severity vulnerability found in shadow/passwd
Description: Incorrect Permission Assignment for Critical Resource
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SHADOW-306230
Introduced through: shadow/passwd@1:4.5-1.1, adduser@3.118, shadow/login@1:4.5-1.1, util-linux/mount@2.33.1-0.1
From: shadow/passwd@1:4.5-1.1
From: adduser@3.118 > shadow/passwd@1:4.5-1.1
From: shadow/login@1:4.5-1.1
and 1 more…

✗ Low severity vulnerability found in shadow/passwd
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SHADOW-306250
Introduced through: shadow/passwd@1:4.5-1.1, adduser@3.118, shadow/login@1:4.5-1.1, util-linux/mount@2.33.1-0.1
From: shadow/passwd@1:4.5-1.1
From: adduser@3.118 > shadow/passwd@1:4.5-1.1
From: shadow/login@1:4.5-1.1
and 1 more…

✗ Low severity vulnerability found in shadow/passwd
Description: Incorrect Permission Assignment for Critical Resource
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SHADOW-539852
Introduced through: shadow/passwd@1:4.5-1.1, adduser@3.118, shadow/login@1:4.5-1.1, util-linux/mount@2.33.1-0.1
From: shadow/passwd@1:4.5-1.1
From: adduser@3.118 > shadow/passwd@1:4.5-1.1
From: shadow/login@1:4.5-1.1
and 1 more…

✗ Low severity vulnerability found in perl/perl-modules-5.28
Description: Link Following
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PERL-327793
Introduced through: autoconf@2.69-11, meta-common-packages@meta
From: autoconf@2.69-11 > perl@5.28.1-6+deb10u1 > perl/perl-modules-5.28@5.28.1-6+deb10u1
From: autoconf@2.69-11 > perl@5.28.1-6+deb10u1 > perl/libperl5.28@5.28.1-6+deb10u1 > perl/perl-modules-5.28@5.28.1-6+deb10u1
From: autoconf@2.69-11 > perl@5.28.1-6+deb10u1 > perl/libperl5.28@5.28.1-6+deb10u1
and 2 more…

✗ Low severity vulnerability found in pcre3/libpcre3
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-345321
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Low severity vulnerability found in pcre3/libpcre3
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-345353
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Low severity vulnerability found in pcre3/libpcre3
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-345502
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Low severity vulnerability found in pcre3/libpcre3
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-345530
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Low severity vulnerability found in pcre3/libpcre3
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-572368
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Low severity vulnerability found in patch
Description: Double Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PATCH-303854
Introduced through: dpkg/dpkg-dev@1.19.7
From: dpkg/dpkg-dev@1.19.7 > patch@2.7.6-3+deb10u1

✗ Low severity vulnerability found in patch
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PATCH-303870
Introduced through: dpkg/dpkg-dev@1.19.7
From: dpkg/dpkg-dev@1.19.7 > patch@2.7.6-3+deb10u1

✗ Low severity vulnerability found in patch
Description: Directory Traversal
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PATCH-303893
Introduced through: dpkg/dpkg-dev@1.19.7
From: dpkg/dpkg-dev@1.19.7 > patch@2.7.6-3+deb10u1

✗ Low severity vulnerability found in openssl/libssl1.1
Description: Cryptographic Issues
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENSSL-374709
Introduced through: openssl/libssl1.1@1.1.1d-0+deb10u3, ca-certificates@20200601~deb10u1, curl@7.64.0-4+deb10u1
From: openssl/libssl1.1@1.1.1d-0+deb10u3
From: ca-certificates@20200601~deb10u1 > openssl@1.1.1d-0+deb10u3 > openssl/libssl1.1@1.1.1d-0+deb10u3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openssl/libssl1.1@1.1.1d-0+deb10u3
and 2 more…

✗ Low severity vulnerability found in openssl/libssl1.1
Description: Cryptographic Issues
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENSSL-374996
Introduced through: openssl/libssl1.1@1.1.1d-0+deb10u3, ca-certificates@20200601~deb10u1, curl@7.64.0-4+deb10u1
From: openssl/libssl1.1@1.1.1d-0+deb10u3
From: ca-certificates@20200601~deb10u1 > openssl@1.1.1d-0+deb10u3 > openssl/libssl1.1@1.1.1d-0+deb10u3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openssl/libssl1.1@1.1.1d-0+deb10u3
and 2 more…

✗ Low severity vulnerability found in openssl/libssl1.1
Description: Information Exposure
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENSSL-536856
Introduced through: openssl/libssl1.1@1.1.1d-0+deb10u3, ca-certificates@20200601~deb10u1, curl@7.64.0-4+deb10u1
From: openssl/libssl1.1@1.1.1d-0+deb10u3
From: ca-certificates@20200601~deb10u1 > openssl@1.1.1d-0+deb10u3 > openssl/libssl1.1@1.1.1d-0+deb10u3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openssl/libssl1.1@1.1.1d-0+deb10u3
and 2 more…

✗ Low severity vulnerability found in openldap/libldap-common
Description: Improper Initialization
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENLDAP-304601
Introduced through: curl@7.64.0-4+deb10u1, openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 > openldap/libldap-common@2.4.47+dfsg-3+deb10u2
From: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2

✗ Low severity vulnerability found in openldap/libldap-common
Description: Cryptographic Issues
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENLDAP-304654
Introduced through: curl@7.64.0-4+deb10u1, openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 > openldap/libldap-common@2.4.47+dfsg-3+deb10u2
From: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2

✗ Low severity vulnerability found in openldap/libldap-common
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENLDAP-304666
Introduced through: curl@7.64.0-4+deb10u1, openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 > openldap/libldap-common@2.4.47+dfsg-3+deb10u2
From: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2

✗ Low severity vulnerability found in openldap/libldap-common
Description: Improper Certificate Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-OPENLDAP-584924
Introduced through: curl@7.64.0-4+deb10u1, openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 > openldap/libldap-common@2.4.47+dfsg-3+deb10u2
From: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2

✗ Low severity vulnerability found in m4
Description: CVE-2008-1688
Info: https://snyk.io/vuln/SNYK-DEBIAN10-M4-277768
Introduced through: autoconf@2.69-11
From: autoconf@2.69-11 > m4@1.4.18-2

✗ Low severity vulnerability found in m4
Description: CVE-2008-1687
Info: https://snyk.io/vuln/SNYK-DEBIAN10-M4-277772
Introduced through: autoconf@2.69-11
From: autoconf@2.69-11 > m4@1.4.18-2

✗ Low severity vulnerability found in lz4/liblz4-1
Description: Buffer Overflow
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LZ4-473072
Introduced through: lz4/liblz4-1@1.8.3-1, apt@1.8.2.1
From: lz4/liblz4-1@1.8.3-1
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > lz4/liblz4-1@1.8.3-1
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4 > lz4/liblz4-1@1.8.3-1

✗ Low severity vulnerability found in libxml2/libxml2
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-429526
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ Low severity vulnerability found in libxml2/libxml2
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-429565
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ Low severity vulnerability found in libtasn1-6
Description: Resource Management Errors
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBTASN16-339585
Introduced through: libtasn1-6@4.13-3, curl@7.64.0-4+deb10u1
From: libtasn1-6@4.13-3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 > gnutls28/libgnutls30@3.6.7-4+deb10u5 > libtasn1-6@4.13-3

✗ Low severity vulnerability found in libssh2/libssh2-1
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBSSH2-474372
Introduced through: libssh2/libssh2-1@1.8.0-2.1, curl@7.64.0-4+deb10u1
From: libssh2/libssh2-1@1.8.0-2.1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > libssh2/libssh2-1@1.8.0-2.1

✗ Low severity vulnerability found in libseccomp/libseccomp2
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBSECCOMP-341044
Introduced through: libseccomp/libseccomp2@2.3.3-4, apt@1.8.2.1
From: libseccomp/libseccomp2@2.3.3-4
From: apt@1.8.2.1 > libseccomp/libseccomp2@2.3.3-4

✗ Low severity vulnerability found in libgcrypt20
Description: Use of a Broken or Risky Cryptographic Algorithm
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBGCRYPT20-391902
Introduced through: libgcrypt20@1.8.4-5, apt@1.8.2.1, curl@7.64.0-4+deb10u1
From: libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > gnupg2/gpgv@2.2.12-1+deb10u1 > libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4 > libgcrypt20@1.8.4-5
and 1 more…

✗ Low severity vulnerability found in krb5/libkrb5support0
Description: CVE-2004-0971
Info: https://snyk.io/vuln/SNYK-DEBIAN10-KRB5-395883
Introduced through: krb5/libkrb5support0@1.17-3, curl@7.64.0-4+deb10u1, krb5/libk5crypto3@1.17-3, krb5/libkrb5-3@1.17-3, krb5/libgssapi-krb5-2@1.17-3
From: krb5/libkrb5support0@1.17-3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > krb5/libgssapi-krb5-2@1.17-3 > krb5/libkrb5support0@1.17-3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > krb5/libgssapi-krb5-2@1.17-3 > krb5/libk5crypto3@1.17-3 > krb5/libkrb5support0@1.17-3
and 10 more…

✗ Low severity vulnerability found in krb5/libkrb5support0
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-KRB5-395955
Introduced through: krb5/libkrb5support0@1.17-3, curl@7.64.0-4+deb10u1, krb5/libk5crypto3@1.17-3, krb5/libkrb5-3@1.17-3, krb5/libgssapi-krb5-2@1.17-3
From: krb5/libkrb5support0@1.17-3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > krb5/libgssapi-krb5-2@1.17-3 > krb5/libkrb5support0@1.17-3
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > krb5/libgssapi-krb5-2@1.17-3 > krb5/libk5crypto3@1.17-3 > krb5/libkrb5support0@1.17-3
and 10 more…

✗ Low severity vulnerability found in gnutls28/libgnutls30
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GNUTLS28-340755
Introduced through: gnutls28/libgnutls30@3.6.7-4+deb10u5, apt@1.8.2.1, curl@7.64.0-4+deb10u1
From: gnutls28/libgnutls30@3.6.7-4+deb10u5
From: apt@1.8.2.1 > gnutls28/libgnutls30@3.6.7-4+deb10u5
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > rtmpdump/librtmp1@2.4+20151223.gitfa8646d.1-2 > gnutls28/libgnutls30@3.6.7-4+deb10u5
and 1 more…

✗ Low severity vulnerability found in gnupg2/gpgv
Description: Use of a Broken or Risky Cryptographic Algorithm
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GNUPG2-535553
Introduced through: gnupg2/gpgv@2.2.12-1+deb10u1, apt@1.8.2.1
From: gnupg2/gpgv@2.2.12-1+deb10u1
From: apt@1.8.2.1 > gnupg2/gpgv@2.2.12-1+deb10u1

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-338106
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-338163
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-356371
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Resource Management Errors
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-356671
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Resource Management Errors
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-356735
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: CVE-2010-4051
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-356875
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-452228
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-452267
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Use of Insufficiently Random Values
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-453375
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Information Exposure
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-453640
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Information Exposure
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-534995
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glibc/libc-dev-bin
Description: Integer Underflow
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-564233
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Low severity vulnerability found in glib2.0/libglib2.0-0
Description: Cryptographic Issues
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIB20-300105
Introduced through: pkg-config@0.29-6
From: pkg-config@0.29-6 > glib2.0/libglib2.0-0@2.58.3-2+deb10u2

✗ Low severity vulnerability found in curl/libcurl4
Description: CVE-2020-8177
Info: https://snyk.io/vuln/SNYK-DEBIAN10-CURL-573151
Introduced through: curl/libcurl4@7.64.0-4+deb10u1, curl@7.64.0-4+deb10u1
From: curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1

✗ Low severity vulnerability found in curl/libcurl4
Description: CVE-2020-8169
Info: https://snyk.io/vuln/SNYK-DEBIAN10-CURL-573153
Introduced through: curl/libcurl4@7.64.0-4+deb10u1, curl@7.64.0-4+deb10u1
From: curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1

✗ Low severity vulnerability found in curl/libcurl4
Description: CVE-2020-8231
Info: https://snyk.io/vuln/SNYK-DEBIAN10-CURL-608200
Introduced through: curl/libcurl4@7.64.0-4+deb10u1, curl@7.64.0-4+deb10u1
From: curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1
From: curl@7.64.0-4+deb10u1

✗ Low severity vulnerability found in coreutils
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-COREUTILS-317465
Introduced through: coreutils@8.30-3
From: coreutils@8.30-3

✗ Low severity vulnerability found in coreutils
Description: Race Condition
Info: https://snyk.io/vuln/SNYK-DEBIAN10-COREUTILS-317494
Introduced through: coreutils@8.30-3
From: coreutils@8.30-3

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-337986
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-337990
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-337992
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-337999
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-338007
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-338012
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403696
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403777
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403817
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403841
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403857
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403861
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403865
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403873
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Use After Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403909
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403933
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Resource Exhaustion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403941
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403945
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403961
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Resource Management Errors
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403977
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403985
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404005
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404033
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404041
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404045
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404049
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404130
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404138
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404150
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404190
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404194
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404206
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Missing Release of Resource after Effective Lifetime
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404210
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404214
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404222
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-404270
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-451156
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-455443
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-455454
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-456012
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-456777
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-472909
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in binutils/binutils-common
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-472913
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Low severity vulnerability found in bash
Description: Improper Check for Dropped Privileges
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BASH-536280
Introduced through: bash@5.0-4
From: bash@5.0-4

✗ Low severity vulnerability found in apt/libapt-pkg5.0
Description: Improper Verification of Cryptographic Signature
Info: https://snyk.io/vuln/SNYK-DEBIAN10-APT-407502
Introduced through: apt/libapt-pkg5.0@1.8.2.1, apt@1.8.2.1
From: apt/libapt-pkg5.0@1.8.2.1
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1
From: apt@1.8.2.1

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: Divide By Zero
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-466337
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-537251
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: Improper Handling of Exceptional Conditions
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-539769
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570318
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570323
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: CVE-2020-13631
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570487
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570498
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in sqlite3/libsqlite3-0
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-574691
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ Medium severity vulnerability found in re2c
Description: Uncontrolled Recursion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-RE2C-567845
Introduced through: re2c@1.1.1-1
From: re2c@1.1.1-1

✗ Medium severity vulnerability found in pcre3/libpcre3
Description: Integer Overflow or Wraparound
Info: https://snyk.io/vuln/SNYK-DEBIAN10-PCRE3-572367
Introduced through: meta-common-packages@meta
From: meta-common-packages@meta > pcre3/libpcre3@2:8.39-12

✗ Medium severity vulnerability found in libxml2/libxml2
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-429393
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ Medium severity vulnerability found in libxml2/libxml2
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-609787
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ Medium severity vulnerability found in libgcrypt20
Description: Cryptographic Issues
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBGCRYPT20-450771
Introduced through: libgcrypt20@1.8.4-5, apt@1.8.2.1, curl@7.64.0-4+deb10u1
From: libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > gnupg2/gpgv@2.2.12-1+deb10u1 > libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4 > libgcrypt20@1.8.4-5
and 1 more…

✗ Medium severity vulnerability found in libgcrypt20
Description: Race Condition
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBGCRYPT20-460489
Introduced through: libgcrypt20@1.8.4-5, apt@1.8.2.1, curl@7.64.0-4+deb10u1
From: libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > gnupg2/gpgv@2.2.12-1+deb10u1 > libgcrypt20@1.8.4-5
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4 > libgcrypt20@1.8.4-5
and 1 more…

✗ Medium severity vulnerability found in glibc/libc-dev-bin
Description: Out-of-Bounds
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-559181
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ Medium severity vulnerability found in binutils/binutils-common
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-337997
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Medium severity vulnerability found in binutils/binutils-common
Description: Allocation of Resources Without Limits or Throttling
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-338006
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ Medium severity vulnerability found in binutils/binutils-common
Description: Resource Exhaustion
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403997
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

✗ High severity vulnerability found in systemd/libsystemd0
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-345386
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ High severity vulnerability found in systemd/libsystemd0
Description: Access Restriction Bypass
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-345391
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ High severity vulnerability found in systemd/libsystemd0
Description: Information Exposure
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SYSTEMD-346788
Introduced through: systemd/libsystemd0@241-7~deb10u4, util-linux/bsdutils@1:2.33.1-0.1, apt@1.8.2.1, util-linux/mount@2.33.1-0.1, systemd/libudev1@241-7~deb10u4
From: systemd/libsystemd0@241-7~deb10u4
From: util-linux/bsdutils@1:2.33.1-0.1 > systemd/libsystemd0@241-7~deb10u4
From: apt@1.8.2.1 > apt/libapt-pkg5.0@1.8.2.1 > systemd/libsystemd0@241-7~deb10u4
and 4 more…

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: CVE-2019-19603
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-537598
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: Unrestricted Upload of File with Dangerous Type
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-539763
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: NULL Pointer Dereference
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-539773
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: Improper Handling of Exceptional Conditions
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-540471
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: CVE-2019-19959
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-540568
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: Use After Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570494
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-570723
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in sqlite3/libsqlite3-0
Description: Use After Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-SQLITE3-571613
Introduced through: sqlite3/libsqlite3-0@3.27.2-3
From: sqlite3/libsqlite3-0@3.27.2-3

✗ High severity vulnerability found in libxml2/libxml2
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-429486
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ High severity vulnerability found in libxml2/libxml2
Description: XML External Entity (XXE) Injection
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-429496
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ High severity vulnerability found in libxml2/libxml2
Description: Missing Release of Resource after Effective Lifetime
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-539775
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ High severity vulnerability found in libxml2/libxml2
Description: Loop with Unreachable Exit Condition (‘Infinite Loop’)
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-542927
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ High severity vulnerability found in libxml2/libxml2
Description: Improper Resource Shutdown or Release
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBXML2-542929
Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3
From: libxml2/libxml2@2.9.4+dfsg1-7+b3

✗ High severity vulnerability found in libssh2/libssh2-1
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBSSH2-452460
Introduced through: libssh2/libssh2-1@1.8.0-2.1, curl@7.64.0-4+deb10u1
From: libssh2/libssh2-1@1.8.0-2.1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > libssh2/libssh2-1@1.8.0-2.1

✗ High severity vulnerability found in libidn2/libidn2-0
Description: Improper Input Validation
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBIDN2-474100
Introduced through: libidn2/libidn2-0@2.0.5-1+deb10u1, curl@7.64.0-4+deb10u1
From: libidn2/libidn2-0@2.0.5-1+deb10u1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > libidn2/libidn2-0@2.0.5-1+deb10u1
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > libpsl/libpsl5@0.20.2-2 > libidn2/libidn2-0@2.0.5-1+deb10u1
and 1 more…

✗ High severity vulnerability found in libbsd/libbsd0
Description: Out-of-bounds Read
Info: https://snyk.io/vuln/SNYK-DEBIAN10-LIBBSD-541041
Introduced through: libbsd/libbsd0@0.9.1-2, libedit/libedit2@3.1-20181209-1
From: libbsd/libbsd0@0.9.1-2
From: libedit/libedit2@3.1-20181209-1 > libbsd/libbsd0@0.9.1-2

✗ High severity vulnerability found in gnutls28/libgnutls30
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GNUTLS28-609778
Introduced through: gnutls28/libgnutls30@3.6.7-4+deb10u5, apt@1.8.2.1, curl@7.64.0-4+deb10u1
From: gnutls28/libgnutls30@3.6.7-4+deb10u5
From: apt@1.8.2.1 > gnutls28/libgnutls30@3.6.7-4+deb10u5
From: curl@7.64.0-4+deb10u1 > curl/libcurl4@7.64.0-4+deb10u1 > rtmpdump/librtmp1@2.4+20151223.gitfa8646d.1-2 > gnutls28/libgnutls30@3.6.7-4+deb10u5
and 1 more…

✗ High severity vulnerability found in glibc/libc-dev-bin
Description: Out-of-bounds Write
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-559488
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ High severity vulnerability found in glibc/libc-dev-bin
Description: Use After Free
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GLIBC-559493
Introduced through: gcc-defaults/g++@4:8.3.0-1, glibc/libc6-dev@2.28-10, glibc/libc-bin@2.28-10, meta-common-packages@meta
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10 > glibc/libc-dev-bin@2.28-10
From: glibc/libc6-dev@2.28-10
From: gcc-defaults/g++@4:8.3.0-1 > gcc-8/g++-8@8.3.0-6 > gcc-8/libstdc++-8-dev@8.3.0-6 > glibc/libc6-dev@2.28-10
and 2 more…

✗ High severity vulnerability found in gcc-8/libstdc++6
Description: Information Exposure
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GCC8-347558
Introduced through: gcc-8/libstdc++6@8.3.0-6, apt@1.8.2.1, icu/libicu63@63.1-6+deb10u1, re2c@1.1.1-1, gcc-defaults/g++@4:8.3.0-1, meta-common-packages@meta
From: gcc-8/libstdc++6@8.3.0-6
From: apt@1.8.2.1 > gcc-8/libstdc++6@8.3.0-6
From: icu/libicu63@63.1-6+deb10u1 > gcc-8/libstdc++6@8.3.0-6
and 30 more…

✗ High severity vulnerability found in gcc-8/libstdc++6
Description: Insufficient Entropy
Info: https://snyk.io/vuln/SNYK-DEBIAN10-GCC8-469413
Introduced through: gcc-8/libstdc++6@8.3.0-6, apt@1.8.2.1, icu/libicu63@63.1-6+deb10u1, re2c@1.1.1-1, gcc-defaults/g++@4:8.3.0-1, meta-common-packages@meta
From: gcc-8/libstdc++6@8.3.0-6
From: apt@1.8.2.1 > gcc-8/libstdc++6@8.3.0-6
From: icu/libicu63@63.1-6+deb10u1 > gcc-8/libstdc++6@8.3.0-6
and 30 more…

✗ High severity vulnerability found in binutils/binutils-common
Description: Missing Release of Resource after Effective Lifetime
Info: https://snyk.io/vuln/SNYK-DEBIAN10-BINUTILS-403318
Introduced through: dpkg/dpkg-dev@1.19.7, gcc-defaults/g++@4:8.3.0-1
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/libbinutils@2.31.1-16 > binutils/binutils-common@2.31.1-16
From: dpkg/dpkg-dev@1.19.7 > binutils@2.31.1-16 > binutils/binutils-x86-64-linux-gnu@2.31.1-16 > binutils/binutils-common@2.31.1-16
and 5 more…

Organization: undefined
Package manager: deb
Project name: docker-image|php
Docker image: php:7.2

Tested 160 dependencies for known vulnerabilities, found 147 vulnerabilities.

For more free scans that keep your images secure, sign up to Snyk at https://dockr.ly/3ePqVcp